[Open-FCoE] FCoE traffic

Rastapur Santosh santosh.rastapur at neterion.com
Fri May 2 00:34:00 UTC 2008


Hi,

	I am trying to test FCoE traffic with my setup. 
I am not able to see the right FCID, status and product 
Identifier on the target side.

Here is my setup (With only the relevant log)

~~~~~~
Target:
~~~~~~
linux-hn1g # fcconf
Name          WWPN                      FC-ID   FC         Network
eth2          20:00:00:0c:fc:00:07:a3        0  No HBA     UP

linux-hn1g # fcconf info
Host Name:                  linux-hn1g
HBA Model:                  fcoe
Node Name:                  10:00:00:0c:fc:00:07:a3
Port Name:                  20:00:00:0c:fc:00:07:a3
Port ID:                    000000
Driver Version:
Vendor Spec ID:             0
Actual Data Rate:           10 Gbps
Supported Data Rates:       10 Gbps
PortType (Topology):        NPort
Total Number of Devices:    1
HBA Status:                 Offline
Model:                      fcoe
Product Identifier:
------------------------------------------------------------------------
----

linux-hn1g # cat /proc/scsi_tgt/scsi_tgt
Device (host:ch:id:lun or name)                             Device
handler
0:0:0:0                                                     dev_disk
0:0:1:0                                                     dev_disk
1:0:0:0                                                     none

linux-hn1g # cat /proc/scsi_tgt/groups/Default/devices
Device (host:ch:id:lun or name)  				Virtual
lun  Options
0:0:1:0                                                        0

~~~~~~~~~~
Initiator:
~~~~~~~~~~
[root at FCoE-Init-163 src]# fcconf
Name          WWPN                      FC-ID   FC         Network
eth2          20:00:00:0c:fc:00:07:d0    10102  Online     UP

[root at FCoE-Init-163 src]# fcconf info
Host Name:                  FCoE-Init-163.(none)
OS Device Name:             eth2
SCSI HBA Name:              host2
HBA Model:                  fcoe
Node Name:                  10:00:00:0c:fc:00:07:d0
Port Name:                  20:00:00:0c:fc:00:07:d0
Port ID:                    010102
Driver Version:             OPENFC HBA 0.26 / 0.26
Vendor Spec ID:             0
Actual Data Rate:           10 Gbps
Supported Data Rates:       10 Gbps
PortType (Topology):        NPort
Total Number of Devices:    1
HBA Status:                 Online
Model:                      fcoe
Product Identifier:         Openfc / fcoe driver attached to eth2
------------------------------------------------------------------------
----

[root at FCoE-Init-163 src]# fcconf remote
eth2 remote ports:
FC ID     WWPN                     State      Role
010101    20:00:00:0c:fc:00:07:a3  Online     FCP Target

[root at FCoE-Init-163 src]# fcconf target
eth2 target ports:
FC ID     WWPN                     State      Role
010101    20:00:00:0c:fc:00:07:a3  Online     FCP Target

[root at FCoE-Init-163 src]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              15G  6.3G  8.0G  44% /
/dev/sda1             494M   22M  447M   5% /boot
tmpfs                 501M  168K  501M   1% /dev/shm

fcping is failing.

[root at FCoE-Init-163 src]# fcping -P 20:00:00:0c:fc:00:07:a3
fcping: destination not found
[root at FCoE-Init-163 src]# fcping -N 10:00:00:0c:fc:00:07:a3
fcping: destination not found

Am I missing some configuration?

Thanks
-Santosh



More information about the devel mailing list