[Open-FCoE] FCoE traffic

Mikkel Hagen mhagen at iol.unh.edu
Fri May 2 15:12:57 UTC 2008


You have the same problem that I saw earlier see my previous email in 
the archives for a work around. The INQUIRY command is not succeeding.

Mikkel Hagen
Project Assistant - Fibre Channel/SAS/SATA Consortiums
Research and Development Engineer - iWARP Consortium	
FC/SAS/SATA:1-603-862-0701  iWARP:1-603-862-5083  Fax:1-603-862-4181
UNH-IOL
121 Technology Drive, Suite 2
Durham, NH 03824



Rastapur Santosh wrote:
> Mikkel,
>
> 	Here is the output of lsscsi and dmesg. What are the other test
> tools I can use for testing?
>
> Target:
> linux-hn1g:/lib/modules/2.6.23-default/extra # lsscsi
> [0:0:0:0]    disk    ATA      ST340014A        8.01  /dev/sda
> [0:0:1:0]    disk    ATA      Maxtor 6K040L0   NAR6  /dev/sdb
> [1:0:0:0]    cd/dvd  SONY     DVD-ROM DDU1615  FYS2  /dev/sr0
>
> dmesg
> ~~~~~
> mtu 1478
> fc_local_port_recv_flogi_req: FLOGI from port WWPN 2000000cfc0007d0
> [5572]: scst_suspend_activity:430:suspend_count 0
> [5572]: scst_suspend_activity:440:Waiting for 0 active commands to
> complete
> [5572]: scst_suspend_activity:442:wait_event() returned
> [5572]: scst_suspend_activity:448:Waiting for 0 active commands finally
> to complete
> [5572]: scst_suspend_activity:450:wait_event() returned
> [5572]: scst_resume_activity:468:suspend_count 0 left
> [5572]: scst: scst_register:347:Target <NULL> (ffff81007e4c3980) for
> template openfct regi
> stered successfully
> [5558]: scst: scst_init_session:4792:Using security group "Default" for
> initiator "2000000
> cfc0007d0"
> [5558]: scst_init_session:4795:Assigning session ffff81007e3b6b88 to acg
> Default
> [5558]: scst_alloc_add_tgt_dev:457:host=0, channel=0, id=1, lun=0, SCST
> lun=0
> [5558]: scst_alloc_set_UA:2578:Adding new UA to tgt_dev ffff810042842e20
> [5570]: scst: scst_parse_cmd:532:***ERROR*** Expected data direction 0
> for opcode 0x12 (ha
> ndler dev_disk, target openfct) doesn't match decoded value 2
> Failed CDB:
>  (h)___0__1__2__3__4__5__6__7__8__9__A__B__C__D__E__F
>    0: 12 00 00 00 24 00   ....$.
> fcping[15228]: segfault at 0000000000000000 rip 00002b0e6f0afa34 rsp
> 00007fff3befc0b8 erro
> r 4
> fcping[15232]: segfault at 0000000000000000 rip 00002b1d46655a34 rsp
> 00007fff64953b18 erro
> r 4
> [5570]: scst: scst_parse_cmd:532:***ERROR*** Expected data direction 0
> for opcode 0x12 (ha
> ndler dev_disk, target openfct) doesn't match decoded value 2
> Failed CDB:
>  (h)___0__1__2__3__4__5__6__7__8__9__A__B__C__D__E__F
>    0: 12 00 00 00 24 00   ....$.
> [5570]: scst: scst_parse_cmd:532:***ERROR*** Expected data direction 0
> for opcode 0x12 (ha
> ndler dev_disk, target openfct) doesn't match decoded value 2
> Failed CDB:
>  (h)___0__1__2__3__4__5__6__7__8__9__A__B__C__D__E__F
>    0: 12 00 00 00 24 00   ....$.
> [5570]: scst: scst_parse_cmd:532:***ERROR*** Expected data direction 0
> for opcode 0x12 (ha
> ndler dev_disk, target openfct) doesn't match decoded value 2
> Failed CDB:
>  (h)___0__1__2__3__4__5__6__7__8__9__A__B__C__D__E__F
>    0: 12 00 00 00 24 00   ....$.
>
>
> Initiator:
> ~~~~~~~~~~
> dmesg
> scsi2 : openfc Driver
> fc_local_port_flogi_resp point-to-point mode<6>fcping[3488]: segfault at
> 0 ip 36c72e73ce sp 7fffe6fde428 error 4 in
> libc-2.5.so[36c7200000+146000]
> fcping[3616]: segfault at 0 ip 36c72e73ce sp 7fffb3397bc8 error 4 in
> libc-2.5.so[36c7200000+146000]
> fcping[3623]: segfault at 0 ip 36c72e73ce sp 7fff226eef18 error 4 in
> libc-2.5.so[36c7200000+146000]
> fcping[3628]: segfault at 0 ip 36c72e73ce sp 7fff5347fca8 error 4 in
> libc-2.5.so[36c7200000+146000]
>
>
> Regards
> -Santosh
>
> -----Original Message-----
> From: Mikkel Hagen [mailto:mhagen at iol.unh.edu] 
> Sent: Friday, May 02, 2008 7:16 AM
> To: Rastapur Santosh
> Cc: devel at open-fcoe.org; Ramkrishna Vepa
> Subject: Re: [Open-FCoE] FCoE traffic
>
> What is the output from lsscsi and the end of dmesg?
> I couldn't get fcping to work either but I can still get SCSI traffic to
>
> work.
>
> Mikkel Hagen
> Project Assistant - Fibre Channel/SAS/SATA Consortiums
> Research and Development Engineer - iWARP Consortium	
> FC/SAS/SATA:1-603-862-0701  iWARP:1-603-862-5083  Fax:1-603-862-4181
> UNH-IOL
> 121 Technology Drive, Suite 2
> Durham, NH 03824
>
>
>
> Rastapur Santosh wrote:
>   
>> Hi,
>>
>> 	I am trying to test FCoE traffic with my setup. 
>> I am not able to see the right FCID, status and product 
>> Identifier on the target side.
>>
>> Here is my setup (With only the relevant log)
>>
>> ~~~~~~
>> Target:
>> ~~~~~~
>> linux-hn1g # fcconf
>> Name          WWPN                      FC-ID   FC         Network
>> eth2          20:00:00:0c:fc:00:07:a3        0  No HBA     UP
>>
>> linux-hn1g # fcconf info
>> Host Name:                  linux-hn1g
>> HBA Model:                  fcoe
>> Node Name:                  10:00:00:0c:fc:00:07:a3
>> Port Name:                  20:00:00:0c:fc:00:07:a3
>> Port ID:                    000000
>> Driver Version:
>> Vendor Spec ID:             0
>> Actual Data Rate:           10 Gbps
>> Supported Data Rates:       10 Gbps
>> PortType (Topology):        NPort
>> Total Number of Devices:    1
>> HBA Status:                 Offline
>> Model:                      fcoe
>> Product Identifier:
>>
>>     
> ------------------------------------------------------------------------
>   
>> ----
>>
>> linux-hn1g # cat /proc/scsi_tgt/scsi_tgt
>> Device (host:ch:id:lun or name)                             Device
>> handler
>> 0:0:0:0                                                     dev_disk
>> 0:0:1:0                                                     dev_disk
>> 1:0:0:0                                                     none
>>
>> linux-hn1g # cat /proc/scsi_tgt/groups/Default/devices
>> Device (host:ch:id:lun or name)  				Virtual
>> lun  Options
>> 0:0:1:0                                                        0
>>
>> ~~~~~~~~~~
>> Initiator:
>> ~~~~~~~~~~
>> [root at FCoE-Init-163 src]# fcconf
>> Name          WWPN                      FC-ID   FC         Network
>> eth2          20:00:00:0c:fc:00:07:d0    10102  Online     UP
>>
>> [root at FCoE-Init-163 src]# fcconf info
>> Host Name:                  FCoE-Init-163.(none)
>> OS Device Name:             eth2
>> SCSI HBA Name:              host2
>> HBA Model:                  fcoe
>> Node Name:                  10:00:00:0c:fc:00:07:d0
>> Port Name:                  20:00:00:0c:fc:00:07:d0
>> Port ID:                    010102
>> Driver Version:             OPENFC HBA 0.26 / 0.26
>> Vendor Spec ID:             0
>> Actual Data Rate:           10 Gbps
>> Supported Data Rates:       10 Gbps
>> PortType (Topology):        NPort
>> Total Number of Devices:    1
>> HBA Status:                 Online
>> Model:                      fcoe
>> Product Identifier:         Openfc / fcoe driver attached to eth2
>>
>>     
> ------------------------------------------------------------------------
>   
>> ----
>>
>> [root at FCoE-Init-163 src]# fcconf remote
>> eth2 remote ports:
>> FC ID     WWPN                     State      Role
>> 010101    20:00:00:0c:fc:00:07:a3  Online     FCP Target
>>
>> [root at FCoE-Init-163 src]# fcconf target
>> eth2 target ports:
>> FC ID     WWPN                     State      Role
>> 010101    20:00:00:0c:fc:00:07:a3  Online     FCP Target
>>
>> [root at FCoE-Init-163 src]# df -h
>> Filesystem            Size  Used Avail Use% Mounted on
>> /dev/sda2              15G  6.3G  8.0G  44% /
>> /dev/sda1             494M   22M  447M   5% /boot
>> tmpfs                 501M  168K  501M   1% /dev/shm
>>
>> fcping is failing.
>>
>> [root at FCoE-Init-163 src]# fcping -P 20:00:00:0c:fc:00:07:a3
>> fcping: destination not found
>> [root at FCoE-Init-163 src]# fcping -N 10:00:00:0c:fc:00:07:a3
>> fcping: destination not found
>>
>> Am I missing some configuration?
>>
>> Thanks
>> -Santosh
>> _______________________________________________
>> devel mailing list
>> devel at open-fcoe.org
>> http://www.open-fcoe.org/mailman/listinfo/devel
>>   
>>     



More information about the devel mailing list