[Open-FCoE] Setup question

charles zhuang charlesz at opengridcomputing.com
Thu Sep 11 22:45:38 UTC 2008


Thanks Joe for your quick response. 
..................
====================================================
The 0e:fc:00 part of the destination address is called the FCOE_OUI
or FC-MAP value.  0xefc00 is the new, correct default used by T11, but
unfortunately, the target code hasn't gotten that patch yet.

If you'd like to try it, edit fcoe/fc_fcoe.h in the target code
to change the values of 0xfcfcfc on lines 38 to 0x0efc00
and on line 46 change 0xfcfcfcfffffe to 0x0fc0e00fffffe.

I haven't tested this recently, so I don't know whether this is the
only issue or not, but it's the first thing stopping you.
It is possible that the initiator may have changed recently in ways that
prevent point-to-point mode (involved here) from working correctly.
======================================================
c.z. Yes, I will try that and let you know the result.

======================================================
I tried vdisk a while ago and it worked for me, so you shouldn't need
a SCSI drive.
.......................
Do that before you start the target fcoe.
======================================================
c.z. Thanks, I will try that. But here I have another question, on
initiator, I can do "echo "ethX" > /sys/module/fcoe/destroy" to stop
fcoe. How can I stop the target side fcoe (instead of a reboot)? Maybe
just rmmod manually?
I try "fcconf <ethX> disable" but I don't think that work.

======================================================
# modprobe fcoe
# echo "ethX" > /sys/module/fcoe/create
to start it.
======================================================
c.z. Thanks. I have no problem to start the initiator, but I like to run
"fcconf remote" and other commands to check on things on initiator. 
I have build the fcconf code along with libHBAAPI.so. But when I run it
from the initiator, I got "Floating point exception". I use the exactly
same procedure and source code to build on target with runs fine. So
somewhere in the fcconf or the lib code did "/0" stuff?

Thanks again for your kindly help.

Charles





More information about the devel mailing list