[Open-FCoE] Initiator and Target setup

Mohanraj Krishnaraj Mohanraj.Krishnaraj at bladenetwork.net
Sat Jan 31 00:12:27 UTC 2009


I was using the Initiator Quickstart guide and using the code under
http://www.open-fcoe.org/wordpress/frame.php?url=http://www.open-fcoe.or
g/openfc/wiki/index.php.

BTW, I figured out that the problem in compilation is due to the path
name I gave for compilation. 

Now I have another problem. Whenever I execute the echo (see below)
command at the initiator, my PC hangs. 

1. modprobe fcoe 
2. echo "ethX" > /sys/module/fcoe/parameters/create

I already installed the latest fixes from
git://open-fcoe.org/openfc/fcoe-fixes.git. 
Any other fixes I need to make it working?

Thanks,
Mohan



-----Original Message-----
From: Vasu Dev [mailto:vasu.dev at linux.intel.com] 
Sent: Friday, January 30, 2009 9:15 AM
To: Mohanraj Krishnaraj
Cc: devel at open-fcoe.org
Subject: Re: [Open-FCoE] Initiator and Target setup

Mohanraj Krishnaraj wrote:
> Hi Joe,
>
>    Thanks for your response. My setup doesn't seem to have fcoeadm.
The
> guides doesn't give any information on installing fcoeadm. 

Which guide you are referring to ?

> I tried it
> searching online and downloaded some software. 

Which some sw, any names of sw you tried ?

> I keep getting
> compilation errors and it needs more and more software. Is there any
> document on how to install fcoeadm?
>   

This link  
http://www.open-fcoe.org/openfc/wiki/index.php/Code_repositories has  
info on code respos and fcoeadm is in user code repo at  
git://open-fcoe.org/openfc/open-fcoe.git

You could also enable FCoE initiator on a ethX interface as per this 
wiki 
http://www.open-fcoe.org/openfc/wiki/index.php/FCoE_Initiator_Quickstart


Confidentiality Notice: This message and any attachments may contain  privileged and confidential information. If you have reason to believe that you are not the intended recipient or a person responsible for delivering this information to an intended recipient, you are hereby notified that any review, dissemination, distribution, or copying of this message is strictly prohibited. Please contact the sender immediately by reply mail and destroy all copies of the original message.





More information about the devel mailing list