[Open-FCoE] [PATCH 3/3] fcoe-utils: check for lldpad.pc

John Fastabend john.r.fastabend at intel.com
Sat Jan 8 00:50:30 UTC 2011


dcbd is deprecated use lldpad for pkg dependencies.

Signed-off-by: John Fastabend <john.r.fastabend at intel.com>
---

 configure.ac       |    4 ++--
 fcoe-utils.spec.in |    4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/configure.ac b/configure.ac
index 0da4c1e..d6a249c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,8 +9,8 @@ PKG_CHECK_MODULES([HBAAPI], [HBAAPI])
 AC_SUBST([HBAAPI_CFLAGS])
 AC_SUBST([HBAAPI_LIBS])
 
-PKG_CHECK_MODULES([DCBD], [dcbd])
-AC_SUBST([DCBD_CFLAGS])
+PKG_CHECK_MODULES([LLDPAD], [lldpad])
+AC_SUBST([LLDPAD_CFLAGS])
 
 AC_CONFIG_FILES([Makefile fcoe-utils.spec include/fcoe_utils_version.h])
 AC_OUTPUT
diff --git a/fcoe-utils.spec.in b/fcoe-utils.spec.in
index e55bcbd..d45b84b 100644
--- a/fcoe-utils.spec.in
+++ b/fcoe-utils.spec.in
@@ -9,8 +9,8 @@ URL:            http://www.open-fcoe.org
 Source0:        http://www.open-fcoe.org/openfc/%{name}-%{version}.tar.gz
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
-BuildRequires:  libHBAAPI-devel dcbd-devel
-Requires:       dcbd
+BuildRequires:  libHBAAPI-devel lldpad-devel
+Requires:       lldpad
 Requires(post):   chkconfig
 Requires(preun):  chkconfig initscripts
 Requires(postun): initscripts




More information about the devel mailing list